Issue detected

Incident Report for Sova Assessment Platform

Resolved

This incident has been resolved.
Posted Sep 29, 2025 - 15:20 UTC

Investigating

We’ve identified a minor issue that may affect a small subset of users. Our engineering team is actively investigating and working to resolve the problem. All other services are operating normally, and we’ll provide updates as soon as they become available.
Posted Sep 29, 2025 - 15:05 UTC
This incident affected: Candidate and Assessor Homepages (Ireland server) and Integrations (Ireland server).